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Περιεχόμενο

▪ Τι είναι το SPSS

▪ Εισαγωγή/Επεξεργασία δεδομένων στον Data Editor

▪ Ελλείπουσες τιμές / Missing values

▪ Περιγραφική Στατιστική

▪ Διαγράμματα
▪ Ιστόγραμμα

▪ Box plot

▪ Διάγραμμα διασποράς / Scatter Plot

▪ Pie Chart …

▪ Επιλογή περιπτώσεων / Select cases

▪ Μετασχηματισμός και τροποποίηση μεταβλητών

▪ Στατιστικές διαδικασίες / One Sample T test

▪ Αποθήκευση δεδομένων



Data Editor

▪ Είναι ένα λογισμικό 
επεξεργασίας στατιστικών 
δεδομένων

▪ Τα δεδομένα 
αποθηκεύονται σε 
μεταβλητές

▪ Κάθε στήλη είναι μία 
μεταβλητή-μονοδιάστατος 
πίνακας δεδομένων με 
όνομα το περιεχόμενο του 
πάνω κελιού της στήλης
και κάθε γραμμή μία 
περίπτωση (case)

Data Editor



Εισαγωγή δεδομένων στο παράθυρο Data Editor

Data Editor

▪ Τα στατιστικά δεδομένα που 
επεξεργαζόμαστε είναι ένα 
σύνολο αριθμητικών ή 
αλφαριθμητικών τιμών

▪ Τα στατιστικά δεδομένα 
μπορεί να
▪ είναι αποθηκευμένα σε 

ένα αρχείο δεδομένων 
.sav του SPSS

▪ Είναι αποθηκευμένα σε 
ένα αρχείο δεδομένων 
.xls ή xlsx του Excel

▪ να μην είναι σε 
ηλεκτρονική μορφή



Άνοιγμα αρχείου

Αν τα δεδομένα είναι 

αποθηκευμένα σε ένα αρχείο 

δεδομένων του SPSS (*.sav) 

τότε επιλέγουμε από το 

μενού του Data Editor 

διαδοχικά

File -> Open -> Data



Άνοιγμα αρχείου Excel

Αν τα δεδομένα είναι 

αποθηκευμένα σε ένα αρχείο 

δεδομένων του Excel (*.xls ή 

*.xlsx) τότε επιλέγουμε από 

το μενού του Data Editor 

διαδοχικά

File -> Open -> Data

και στο παράθυρο που 

εμφανίζεται επιλέγουμε Excel 

(*.xls, *.xlsx, *.xlsm) στο 

πεδίο Files of type



Εισαγωγή δεδομένων στο παράθυρο Data Editor

Data Editor

Αν τα δεδομένα δεν είναι σε 

ψηφιακή μορφή, τότε τα 

πληκτρολογούμε στις στήλες του 

Data Editor

Στον Data Editor τα δεδομένα 

εμφανίζονται με έναν από τους 

παρακάτω δύο τρόπους:

▪ Data View

▪ Variable View



Data View / Variable View

▪ Data View: Εδώ 

εμφανίζονται οι 

τιμές των δεδομένων

▪ Variable View: Εδώ 

ρυθμίζουμε τις 

μεταβλητές

Data Editor



Data Editor

▪ Name: Όνομα μεταβλητής

▪ Type: Ο τύπος της μεταβλητής

▪ Width: Ο αριθμός των ψηφίων

▪ Decimals: ο αριθμός των δεκαδικών

▪ Label: Η ετικέτα/περιγραφή της μεταβλητής

▪ Values: Οι ετικέτες των τιμών των μεταβλητών

▪ Missing: Κωδικοποίηση των ελλειπουσών τιμών

▪ Columns: Το πλάτος της στήλης

▪ Align: Η στοίχιση των στοιχείων των κελιών (Left, Right, Center)

▪ Measure: Το επίπεδο μέτρησης της μεταβλητής (Ordinal, Nominal, Scale)

▪ Role: Ο ρόλος της μεταβλητής σε μία ανάλυση



Παράδειγμα (Data View)

Στην διπλανή εικόνα φαίνονται το φύλο και τα επίπεδα 
αιμοσφαιρίνης 20 ατόμων (data1.sav).



Παράδειγμα (Variable View)

• Scale: Ποσοτικές μεταβλητές όπως π. χ. το 
βάρος, το ύψος κλπ.

• Nominal: Κατηγορικές μεταβλητές 
(ποιοτικές) π. χ. το φύλο κλπ.

• Ordinal: Διατεταγμένες μεταβλητές π. χ.
• 0 = «πολύ δυσαρεστημένος»
• 1 = «δυσαρεστημένος»
• 2 = «αδιάφορος»
• 3 = «ικανοποιημένος»
• 4 = «πολύ ικανοποιημένος»



Ελλείπουσες τιμές (missing values)

▪ Ελλείπουσες τιμές (missing values) λέμε τις μη 

καταχωρημένες τιμές μία μεταβλητής.

▪ Το SPSS καταχωρεί αυτόματα το σύμβολο του δεκαδικού 

σημείου (κόμμα ή τελεία ανάλογα με τις ρυθμίσεις των 

windows).

▪ Αν για παράδειγμα το εύρος των δυνατών απαντήσεων 

είναι 0 – 250 (π. χ. το ύψος ατόμων σε cm) τότε σαν 

ελλείπουσες τιμές θα μπορούσαμε να χρησιμοποιήσουμε 

τις: -1 = «δεν θέλω να απαντήσω», 999 = «δεν γνωρίζω».

▪ Στις αλφαριθμητικές μεταβλητές το κενό θεωρείται έγκυρη 

καταχώρηση. Αν θέλουμε να θεωρηθεί ελλείπουσα τιμή, 

τότε πρέπει να καταχωρηθεί ως Missing Values.



Explore

▪ Επιλέγουμε Analyze -> Descriptive 

Statistics -> Explore 

▪ Σέρνουμε την μεταβλητή hgb στο πλαίσιο 

Dependent List

▪ Πατάμε ΟΚ

Με την διαδικασία αυτή λαμβάνουμε την τιμή κάποιων στατιστικών 

συναρτήσεων για μία μεταβλητή όπως sample size, mean, median, minimum, 

maximum, standard deviation, variance, range, standard error κ.α.



▪ Η αριστερή πλευρά του 
Viewer περιέχει ένα γενικό 
περίγραμμα των 
αποτελεσμάτων.

▪ Με κλικ πάνω σε κάποιο 
αποτέλεσμα 
μεταφερόμαστε σε αυτό

▪ Η δεξιά πλευρά περιέχει 
στατιστικούς πίνακες, 
διαγράμματα και κείμενο

▪ Μέσω copy – paste είναι 
εφικτή η μεταφορά ενός 
αποτελέσματος σε άλλο 
πρόγραμμα π. χ. MS Word

12.49±1.30



Frequencies

Με την διαδικασία αυτή λαμβάνουμε επίσης την τιμή κάποιων στατιστικών συναρτήσεων για μία μεταβλητή όπως 

sample size, mean, median, minimum, maximum, standard deviation, variance, range, standard error κ.α.

Επιλέγουμε Analyze -> Descriptive Statistics -> Frequencies και στην συνέχεια Statistics



Αρχείο εξόδου

12.49±1.30



Histogram

Επιλέγουμε Analyze -> Descriptive Statistics -> Frequencies και στην συνέχεια Charts





Box Plot

Επιλέγουμε Analyze -> Descriptive Statistics -> Explore και στην συνέχεια Plots



▪ Η μεσαία γραμμή στο κουτί, 
παριστάνει την διάμεσο, ενώ η κάτω 
και άνω πλευρά του κουτιού, 
παριστάνει το 1ο (Q1, 25%) και 3ο

(Q3, 75%) τεταρτημόριο (Quantiles).
▪ Η περιοχή ανάμεσα στο 1ο και 3ο

τεταρτημόριο περιέχει το 50% των 
παρατηρήσεων.

▪ Οι κάθετες γραμμές, που 
καταλήγουν στις δύο οριζόντιες, 
παριστάνουν την μικρότερη και 
μεγαλύτερη τιμή του δείγματός μας.

▪ Οι τιμές που βρίσκονται έξω από τις 
κάθετες γραμμές αποτελούν τις 
ακραίες/εξωτερικές τιμές του 
δείγματος.



Επιλέγουμε Analyze -> Descriptive Statistics -> Explore

Ανάλυση δεδομένων κατά ομάδες



12.23±1.22

12.74±1.40





Ανάλυση δύο κατηγορικών μεταβλητών

▪ Με την εντολή crosstabs παρουσιάζεται σε μορφή πίνακα η σχέση δύο ποιοτικών 
μεταβλητών
▪ Τέτοιες είναι οι μεταβλητές που έχουν διακριτές κατηγορίες, δηλ. αυτές χωρίς 

καμιά σειρά κατάταξης/ιεράρχησης, όπως είναι το φύλο (γυναίκα, άνδρας), 
απαντήσεις (ναι, όχι) κ.α.

▪ Μπορεί να χρησιμοποιηθεί και για συνεχή δεδομένα μόνο όταν αυτά είναι 
ομαδοποιημένα σε επιμέρους κατηγορίες, όπως η ηλικία (0-19, 20-39, 40-59, 60-
79, 80-99)

▪ Μπορεί να παρουσιαστεί η σχέση δύο μεταβλητών με βάση κάποια τρίτη 
μεταβλητή (διαστρωμάτωση)

▪ Με την εντολή crosstabs εκτελείται και η γνωστή χ2 δοκιμασία (chi-square test)





Επιλέγουμε Analyze -> Descriptive Statistics -> Crosstabs (crosstabs.sav)

Ανάλυση δύο κατηγορικών μεταβλητών, χωρίς διαστρωμάτωση







Ανάλυση δύο κατηγορικών μεταβλητών, με διαστρωμάτωση



Επιλέγουμε Analyze -> Descriptive Statistics -> Crosstabs (crosstabs.sav)

Ανάλυση δύο κατηγορικών μεταβλητών, με διαστρωμάτωση







Scatter Plot

To βάρος του σώματος και ο όγκος πλάσματος 8 ανδρών 
είναι:

Α/Α βάρος Kg (x)   όγκος lt (y)
------------------------------------------
1 58.0 2.75
2 70.0 2.86
3 74.0 3.37
4 63.5 2.76
5 62.0 2.62
6 70.5 3.49
7 71.0 3.05
8 66.0 3.12

Θέλουμε να κατασκευάσουμε ένα Scatter plot
για να δούμε αν υπάρχει σχέση μεταξύ όγκου 
πλάσματος και βάρος σώματος.

Καταχωρήστε τους όγκους πλάσματος και βάρος σώματος από τα 8 άτομα, και δώστε στη μία 
μεταβλητή το όνομα volume και στην άλλη το όνομα weight



Scatter Plot

Variable View

Data View



Scatter Plot

3. Με Drag & Drop 
σέρνουμε τις μεταβλητές 
στους άξονες

2. Με Drag & Drop 
σέρνουμε το διάγραμμα 
στο πάνω μέρος

1. Επιλέγουμε Scatter/Dot

Επιλέγουμε Graphs -> Chart Builder και στην συνέχεια Charts





Περιγραφική Στατιστική
Παράδειγμα (data2.sav)

Έστω ο διπλανός πίνακας που περιέχει τις μεταβλητές

▪ chol (δείκτη χοληστερίνης)
▪ sex (φύλο)
▪ age (ηλικία)
▪ drug (ποσότητα ενός ληφθέντος φαρμάκου

▪ 0: καθόλου
▪ 1: ελάχιστη
▪ 2: μικρή
▪ 3: μέτρια



Descriptive

Πατάμε Continue και στην συνέχεια ΟΚ οπότε εμφανίζεται ο ακόλουθος στατιστικός 
πίνακας

Επιλέγουμε από το μενού Analyze -> 
Descriptive Statistics -> Descriptive και 
κάνουμε τις ρυθμίσεις όπως στις διπλανές 
εικόνες:



Frequencies

Πατάμε Continue και στην συνέχεια ΟΚ
οπότε εμφανίζεται ο στατιστικός πίνακας (3)

2

Επιλέγουμε από το μενού Analyze -> Descriptive Statistics -> Frequencies
και κάνουμε τις ρυθμίσεις όπως στις εικόνες (1) και (2):

1

3



Explore

Από το πλήκτρο Options γίνεται η διαχείριση των ελλειπουσών τιμών. 
Πατώντας το κουμπί εμφανίζεται το παράθυρο της επόμενης διαφάνειας

Επιλέγουμε από το μενού Analyze -> Descriptive Statistics -> Explore



Explore

Exclude cases listwise

▪ Στα περιγραφικά μέτρα που θα προκύψουν χρησιμοποιούνται μόνο οι 
περιπτώσεις που είναι ταυτόχρονα έγκυρες σε όλες τις μεταβλητές που έχουν 
εισαχθεί στις Dependent List και Factor List

Exclude cases pairwise

▪ Στα περιγραφικά μέτρα που θα προκύψουν χρησιμοποιούνται όλες οι 
περιπτώσεις που είναι έγκυρες για κάθε μεταβλητή που έχει εισαχθεί στην 
Dependent List

Report values

▪ Οι παρατηρήσεις με ελλείπουσες τιμές αναλύονται ως ξεχωριστή κατηγορία



Explore

Exclude cases listwise



Explore

Exclude cases pairwise



Ιστόγραμμα

Επιλέγουμε από το μενού Analyze -> Descriptive Statistics -> 
Frequencies και κάνουμε τις ρυθμίσεις όπως στην διπλανή 
εικόνα (1):

Πατάμε Continue και 
στην συνέχεια ΟΚ
οπότε εμφανίζονται τα 
γραφήματα (2) και (3)

1
2

3



Ιστόγραμμα

Επιλέγουμε από το μενού Graphs -> Legacy Dialogs -> Histogram
και κάνουμε τις ρυθμίσεις όπως στην παρακάτω εικόνα (1):

Πατάμε ΟΚ οπότε 
εμφανίζεται το 
ιστόγραμμα (2)

1

Σημείωση: Μπορούμε να αλλάξουμε διάφορα χαρακτηριστικά 
του ιστογράμματος, αλλά και κάθε γραφήματος, που 
παράγεται κάνοντας διπλό κλικ στο ιστόγραμμα και 
αλλάζοντας κατάλληλα διάφορες παραμέτρους (π. χ. το 
πλήθος των κλάσεων)

2



Pie chart

Επιλέγουμε από το μενού Analyze -> 
Descriptive Statistics -> Frequencies και 
κάνουμε τις ρυθμίσεις όπως στην διπλανή 
εικόνα (1):

Πατάμε Continue και 
στην συνέχεια ΟΚ
οπότε εμφανίζονται τα 
γραφήματα (3) και (4)

3

1

4



Επιλογή περιπτώσεων (select cases)



Επιλογή περιπτώσεων (select cases)

Έστω ότι στο παράδειγμα της διαφάνειας 10 
θέλουμε να υπολογίσουμε τη μέση τιμή και την 
τυπική απόκλιση των επιπέδων αιμοσφαιρίνης 
μόνο για τις γυναίκες

Επιλέγουμε διαδοχικά Data -> Select cases

Στο παράθυρο που εμφανίζεται επιλέγουμε If 
condition is satisfied

Κάνουμε κλικ στο κουμπί if οπότε ανοίγει το 
παράθυρο Select Cases: if …



Επιλογή περιπτώσεων (select cases)

… εισάγουμε την συνθήκη sex = 0, πατάμε

Continue και μετά ΟΚ



Επιλογή περιπτώσεων (select cases)

Με τον τρόπο αυτό οι ενέργειες που θα γίνουν στη συνέχεια 

θα εφαρμοστούν μόνο στις τιμές των οποίων οι αντίστοιχες 

τιμές της μεταβλητής sex είναι 0



Επιλογή περιπτώσεων (select cases)

Οπότε επιλέγοντας και πάλι διαδοχικά Analyze -> Descriptive 

Statistics -> Explore και στην συνέχεια ΟΚ εμφανίζεται το 

αποτέλεσμα της διπλανής εικόνας οι υπολογισμοί των οποίων 

έγιναν μόνο για τις περιπτώσεις όπου η τιμή της μεταβλητής sex

είναι 0 12.15±1.35



Μετασχηματισμός και τροποποίηση μεταβλητών

▪ Αν θέλουμε να τροποποιήσουμε/μετασχηματίσουμε μια μεταβλητή, είτε υπολογίζοντας τον λογάριθμο της είτε 
διαιρώντας την με ένα αριθμό, αυτό μπορούμε να το πετύχουμε, επιλέγοντας από το μενού επιλογών Transform-
> Compute Variable.

▪ Το SPSS έρχεται με μια μεγάλη λίστα συναρτήσεων που μπορούμε να εφαρμόσουμε σε μια μεταβλητή. Μας δίνει 
επίσης την δυνατότητα να δημιουργήσουμε και νέες κάνοντας διάφορους συνδυασμούς.



Μετασχηματισμός και τροποποίηση μεταβλητών

Για να μετασχηματίσουμε τα δεδομένα της 
μεταβλητής hgb σε φυσικούς λογαρίθμους, 
ακολουθούμε τα παρακάτω βήματα:

1. Στο πλαίσιο Target Variable ορίζουμε 
τη νέα μεταβλητή ln_hgb

2. Επιλέγουμε τη συνάρτηση
LN(numexpr) και την σέρνουμε στο 
πλαίσιο Numeric Expression

3. Σέρνουμε την μεταβλητή hgb στο 
πλαίσιο Numeric Expression

4. Κάνουμε κλικ στο OK



Μετασχηματισμός και τροποποίηση μεταβλητών

Αυτόματα δημιουργείται στον Data 
Editor η μεταβλητή ln_hbg και τιμές τις 
ζητούμενες



Στατιστικές διαδικασίες / One Sample T test

▪ Για να εφαρμόσουμε μία στατιστική διαδικασία σε 
μία η περισσότερες μεταβλητές χρησιμοποιούμε το 
μενού Analyze και στην συνέχεια το αντίστοιχο 
υπομενού

▪ Για παράδειγμα για την διεξαγωγή T test επιλέγουμε 
διαδοχικά Analyze -> Compare means -> One Sample 
T test οπότε εμφανίζεται το παράθυρο της επόμενης 
διαφάνειας



One Sample T test

Κάνοντας τις ρυθμίσεις όπως φαίνονται στην εικόνα 
(1) εμφανίζεται το αποτέλεσμα της εικόνας (2)1

2



Αποθήκευση δεδομένων

▪ Μπορούμε να αποθηκεύσουμε στο δίσκο το output.
▪ Από το μενού επιλογών διαλέγουμε File -> Save As και στo πεδίο File name, δίνουμε το όνομα του αρχείου 

π.χ. output.spv. Έτσι θα μπορέσουμε αργότερα να ανακτήσουμε τα αποτελέσματα της ανάλυσης που έχουμε 
κάνει.



Αποθήκευση δεδομένων

▪ Μπορούμε επίσης να αποθηκεύσουμε και τα δεδομένα του Data Viewer σε κάποιο αρχείο, για μελλοντική 
χρήση.

▪ Έτσι από το μενού επιλογών, διαλέγουμε File -> Save As. Στο πεδίο File name, δίνουμε το όνομα του αρχείου 
που θέλουμε να αποθηκεύσουμε τα δεδομένα π.χ. data.sav.


